بایگانی

آموزش مقدماتی نصب و راه اندازی LAMP در CentOS

LAMP سرنام Linux، Apache، Mysql و PHP می باشد این چهار نرم افزار بیشتر مواقع در کنار هم نصب و پیکربندی می شوند تا پذیرای صفحات پویای وب باشند در این نوشته روش نصب و راه اندازی اولیه آن را مورد بررسی قرار خواهیم داد در این نوشته فرض بر این است که نسخه ۷ سیستم عامل CentOS از قبل به عنوان اولین نرم افزار این پشته نصب شده است.

ادامه خواندن “آموزش مقدماتی نصب و راه اندازی LAMP در CentOS”

آموزش مقدماتی نصب و راه اندازی LAMP در CentOS

LAMP سرنام Linux، Apache، Mysql و PHP می باشد این چهار نرم افزار بیشتر مواقع در کنار هم نصب و پیکربندی می شوند تا پذیرای صفحات پویای وب باشند در این نوشته روش نصب و راه اندازی اولیه آن را مورد بررسی قرار خواهیم داد در این نوشته فرض بر این است که نسخه ۷ سیستم عامل CentOS از قبل به عنوان اولین نرم افزار این پشته نصب شده است.

ادامه خواندن “آموزش مقدماتی نصب و راه اندازی LAMP در CentOS”

صفر تا صد هاستینگ با کنترل پنل Directadmin

در این دوره ما در مورد دایرکت ادمین صحبت میکنیم که چی هست! ‌به سایت دایرکت ادمین سری می‌زنیم و الزامات اون رو بررسی می‌کنیم. شما رو با vmware esxi آشنا می‌کنیم و بهتون می‌گم که چطوری با SSH فایل سیستم عامل CentOS رو به روی اون دانلود کنید. نحوه سنتوس رو به شما می‌آموزیم به همراه دستوراتی که نیاز هست بدونید چیکار می‌کنه. شما رو با پارتیشن بندی LVM آشنا می‌کنیم و نحوه پارتیشن بندی LVM رو بهتون می‌آموزیم. پیش‌نیازها رو نصب می‌کنیم. و شروع به نصب دایرکت ادمین با توضیحات کامل می‌کنیم. در مورد پلاگین‌های مورد نیاز صحبت می‌کنیم مثل نصب فایروال ایمیل منیجر و…

ادامه خواندن “صفر تا صد هاستینگ با کنترل پنل Directadmin”

کشف ۳ آسیب‌پذیری روز-صفرم در PHP 7

سه آسیب‌پذیری روز-صفرم در PHP ۷ کشف شده و به مهاجمان اجازه می‌دهد کنترل نزدیک به ۸۰ درصد از وب‌گاه‌ها را در دست بگیرند. این وب‌گاه‌ها از آخرین نسخه‌ی زبان برنامه‌نویسی PHP استفاده می‌کنند. این آسیب‌پذیری‌ها در سازوکارِ غیرسریال این زبان برنامه‌نویسی کشف شده است و به نفوذگران اجازه می‌دهد با ارسال داده‌های جعلی و مخرب در کوکی‌های کارخواه، وب‌گاه‌های دروپال، جوملا، Magento و vBulletin را آلوده کنند.

ادامه خواندن “کشف ۳ آسیب‌پذیری روز-صفرم در PHP 7”

وردپرس: تمام میزبان‌ها باید به‌طور پیش‌فرض از SSL پشتیبانی کنند

در تلاش برای افزایش امنیت و حریم خصوصی کاربران، وردپرس اعلام کرد که ویژگی‌های جدید این CMS نیازمند این است که میزبان‌ها از SSL پشتیبانی کنند. با آغاز سال ۲۰۱۷ وردپرس تنها به میزبان‌هایی که به‌طور پیش‌فرض دارای گواهی‌نامه‌های SSL هستند، سرویس ارائه خواهد داد. در ادامه وردپرس استفاده از SSL را بر روی ویژگی‌های مختلف ارزیابی کرده و اگر بر روی میزبان‌ها SSL در دسترس باشد، این ویژگی‌ها فعال خواهند شد.

ادامه خواندن “وردپرس: تمام میزبان‌ها باید به‌طور پیش‌فرض از SSL پشتیبانی کنند”